Trouble code P2135 : V-Twin Forum: Harley Davidson Forums
» Sponsors

» Insurance
Go Back   V-Twin Forum : Harley-Davidson Motorcycle Forums > Technical Discussion Forums > Twin-Cam 96" Engine Technical Discussion
New User? Register Forgot Password

Reply
 
LinkBack Thread Tools Display Modes
Old 11-03-2010, 08:03 PM   #1 (permalink)
Seasoned Rider
 
Join Date: Jan 2010
Location: Phoenix Az
Posts: 83
azlou66 wants to know Dino or Syn?
Trouble code P2135

2008 StreetGlide hit limp mode today checked the code and pulled P2135. Anyone know the quick, I Pray , easy fix??????
azlou66 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-04-2010, 08:20 AM   #2 (permalink)
IronButt
 
Join Date: Dec 2005
Location: Cypress, TX
Posts: 259
UltraNutz wants to know Dino or Syn?
that's a throttle position sensor correlation error.

turn ignition on until engine light goes off, then turn ignition off again. repeat this 5 times and it resets the memory
UltraNutz is offline   Reply With Quote
Old 11-04-2010, 11:03 AM   #3 (permalink)
Seasoned Rider
 
Join Date: Jan 2010
Location: Phoenix Az
Posts: 83
azlou66 wants to know Dino or Syn?
Thanks Nutz, thats what I thought good to verify.
azlou66 is offline   Reply With Quote
Old 11-04-2010, 11:07 AM   #4 (permalink)
IronButt
 
Join Date: Dec 2005
Location: Cypress, TX
Posts: 259
UltraNutz wants to know Dino or Syn?
glad to help.. hope that resolves it...

i'm not a big fan of this TBW setup. too many damn variables. What happened to the good ole cable way of accelerating! All these engineers now-a-days fixing things that aren't broken. :-)
UltraNutz is offline   Reply With Quote
Old 11-10-2010, 06:45 PM   #5 (permalink)
Seasoned Rider
 
Join Date: Jan 2010
Location: Phoenix Az
Posts: 83
azlou66 wants to know Dino or Syn?
Reset memory per Nutz advice all was fine for a few days now problem has returned!! Any advice, hints etc.??????
azlou66 is offline   Reply With Quote
Old 11-11-2010, 12:37 AM   #6 (permalink)
Seasoned Rider
 
dynodude's Avatar
 
Join Date: Jan 2007
Location: SOUTHERN CALIFORNIA
Posts: 33
dynodude wants to know Dino or Syn?
Quote:
Originally Posted by azlou66 View Post
Reset memory per Nutz advice all was fine for a few days now problem has returned!! Any advice, hints etc.??????
Take that bike back to the dealer immediatly. You need to have this condition documented with them and show that you have repeatedly tried to have it fixed. Not sure what the lemon laws are in AZ, but in Cali, 3 time back for the same problem and they have to give you another bike. I personally know 3 people , all with 08 touring bikes that are now riding 10"s and 11"s for exactly the same issues.
dynodude is offline   Reply With Quote
Old 11-11-2010, 09:20 AM   #7 (permalink)
IronButt
 
Join Date: Dec 2005
Location: Cypress, TX
Posts: 259
UltraNutz wants to know Dino or Syn?
- the IAC may be dirty and could probably use a good cleaning.
- The IAC is located in the throttle body.
- to clean the IAC, turn ignition switch on, turn run/stop switch on and off a couple of times while spraying carburetor cleaner into the IAC. You should be able to put your finger over the IAC and feel it moving. Just a tad bit of dirt in these things will cause havoc..
- if the bike is in warranty and the above doesn't work, I would certainly take it to the dealer. there are known issues relating to this and I believe a service bulletin came out (TT410) addressing these TBW and IAC issues. It seems that some require an ECM flash to correct the issue and some simply require replacing the IAC. if it's out of warranty, I believe an IAC costs about $45 to replace.

Last edited by UltraNutz; 11-11-2010 at 09:28 AM.
UltraNutz is offline   Reply With Quote
Old 11-11-2010, 10:00 AM   #8 (permalink)
IronButt
 
Join Date: Dec 2005
Location: Cypress, TX
Posts: 259
UltraNutz wants to know Dino or Syn?
This was also posted by harleytuner on HDFORUMS.

Your idle runs off of IAC motors, The voltage across both motors always has to be 5V, i.e. 1 can be .7 so the other has to be 4.3. If the motors don't =5 the bike won't idle right. What happens is sometimes if you shut the bike off before it comes to an idle the IAC motors (for lack of better terms) re-calibrate themselves to when the bike was shut off. There is some debate as to the proper way to shut the bike off, some say DO NOT use the run/kill switch on your handlebars as this only shuts off certain things (soft kill) the lights are on etc.etc. They say to ONLY use the ignition kill to shut your bike off as this shuts everything down simultaniously. It makes sence to me, you have to remember, your basically shutting of a computer now, and like your PC at home, if you don't shut it down properly sooner or later you will have hardware/software issues.
UltraNutz is offline   Reply With Quote
Old 11-11-2010, 07:47 PM   #9 (permalink)
Seasoned Rider
 
Join Date: Jan 2010
Location: Phoenix Az
Posts: 83
azlou66 wants to know Dino or Syn?
Dyna, had the bike since July 2008 no warranty left. Nutz what about a problem with the grip twist sensor???????? Possible???????? My Panheads and Shovels were alot easier to work on!
azlou66 is offline   Reply With Quote
Old 11-12-2010, 09:27 AM   #10 (permalink)
IronButt
 
Join Date: Dec 2005
Location: Cypress, TX
Posts: 259
UltraNutz wants to know Dino or Syn?
Azlou66, aboslutely it could be the grip sensor. If dirt gets in there or if the plastic seal cap gets deformed, that would certainly cause the issues you're seeing. The good thing about that is if it has to be replaced, it's like a $75 part for piece of mind. :-)

Last edited by UltraNutz; 11-12-2010 at 10:06 AM.
UltraNutz is offline   Reply With Quote
Old 11-12-2010, 09:30 AM   #11 (permalink)
IronButt
 
Join Date: Dec 2005
Location: Cypress, TX
Posts: 259
UltraNutz wants to know Dino or Syn?
i have a really stupid comment (or what may seem stupid)

are you sure it's not the OP that may be causing this issue, rolling the throttle forward and backward in certain circumstances will make the ECM recalibrate itself to new idle positions
UltraNutz is offline   Reply With Quote
Old 11-12-2010, 11:27 AM   #12 (permalink)
Seasoned Rider
 
Join Date: Jan 2010
Location: Phoenix Az
Posts: 83
azlou66 wants to know Dino or Syn?
Nutz I don't roll the throttle unless I am going down the road.
azlou66 is offline   Reply With Quote
Old 11-12-2010, 11:28 AM   #13 (permalink)
Seasoned Rider
 
Join Date: Jan 2010
Location: Phoenix Az
Posts: 83
azlou66 wants to know Dino or Syn?
I am going to tear into it and check the wiring for any prolems.
azlou66 is offline   Reply With Quote
Old 11-12-2010, 11:55 AM   #14 (permalink)
IronButt
 
Join Date: Dec 2005
Location: Cypress, TX
Posts: 259
UltraNutz wants to know Dino or Syn?
sorry, kinda thought you were working on the bike for someone else. :-)
UltraNutz is offline   Reply With Quote
Old 11-13-2010, 09:50 AM   #15 (permalink)
MCE
IronButt
 
Join Date: Dec 2009
Location: Mi,South of the D
Posts: 838
MCE wants to know Dino or Syn?
I have a 2008 FLHX and to the best of my memory I had the same code. it wound up being the lock on the ECM plug wasn't locked and throwing that code along with a few other codes. it's under your seat and it's a small arm that locks into place on the side of the plug.

hope this is the answer to your problem, as sometimes it's an easy fix and not the most complex one.
__________________
motorcycle enthusiast
MCE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
(C)2001-2012 V-twinForum.com All Rights Reserved (C)2001- V-twinForum.com All Rights Reserved
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum