Screamin Eagle Cam Plate and Oil Pump : V-Twin Forum: Harley Davidson Forums
» Sponsors

» Insurance
Go Back   V-Twin Forum : Harley-Davidson Motorcycle Forums > Technical Discussion Forums > Twin-Cam 88" Engine Technical Discussion
New User? Register Forgot Password

Reply
 
LinkBack Thread Tools Display Modes
Old 05-30-2008, 11:00 AM   #1 (permalink)
Premium Member
 
aldean's Avatar
 
Join Date: Feb 2008
Location: Oakley, California
Posts: 359
aldean wants to know Dino or Syn?
Screamin Eagle Cam Plate and Oil Pump

I have a 99 Road King at a shop having a GMR 107 kit with the RR615 cam being installed. I had them order and install the Screamin Eagle cam plate and high volume oil pump part # 25283-07. They called me and said the oil pump didn't work. They said they replaced the oil pump again and that one didn't work either. They said they went ahead and installed the oil pump with the one that the owner uses in his bikes which is the same price. So that tells me they didn't go with a feuling oil pump. Are there other oil pumps that still have the high volume? Could they have been doing something wrong with the install? I'm concerned now....Any input will be greatly appreciated.
aldean is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-30-2008, 11:58 AM   #2 (permalink)
Fastest Chkn N the South!
 
Colonel Sanders's Avatar
 
Join Date: May 2007
Location: ROLL TIDE!!!
Posts: 897
Colonel Sanders wants to know Dino or Syn?
If I'm not mistaken, the SE plate is only for the new style pump. Is that the new style pump?

I'm running the SE plate and new style HD pump in my 124" and it's working just fine.
__________________
'01 Deuce
GMR 124"
4.125" x 4.625"
CV51 carb/intake/AC
R&R Stage IV heads
10.8:1 CR
JE -10cc pistons
S&S 640 cams
Axtell cylinders
JIMS/Darkhorse crank
Rivera Pro Clutch
DTT ignition
Hooker Troublemaker pipes
137/134 STD 134/130 SAE
Colonel Sanders is offline   Reply With Quote Quick reply to this message
Old 05-30-2008, 12:13 PM   #3 (permalink)
Premium Member
 
aldean's Avatar
 
Join Date: Feb 2008
Location: Oakley, California
Posts: 359
aldean wants to know Dino or Syn?
It's the kit # 25283-07

This is a complete kit. Unless they tried to piece it together to save money and charge me the kit price. I will find out. Thanks.
aldean is offline   Reply With Quote Quick reply to this message
Old 05-30-2008, 12:15 PM   #4 (permalink)
Premium octane member
 
TXCHOP's Avatar
 
Join Date: May 2004
Location: Downstate NY
Posts: 7,380
TXCHOP wants to know Dino or Syn?
I am running it in my build as well. No problems here. I did hear of one instance where it was sumping though.

Wonder what brand they gave you?
__________________
S&S T124
TXCHOP is offline   Reply With Quote Quick reply to this message
Old 05-30-2008, 01:35 PM   #5 (permalink)
Premium Member
 
aldean's Avatar
 
Join Date: Feb 2008
Location: Oakley, California
Posts: 359
aldean wants to know Dino or Syn?
???Oil Pump

I will post the info as soon as I know. This one of those wish I would have went to RC Cycles!
aldean is offline   Reply With Quote Quick reply to this message
Old 05-30-2008, 01:46 PM   #6 (permalink)
IronButt
 
Join Date: Jun 2004
Location: montana
Posts: 2,385
Mtclassic wants to know Dino or Syn?
I have over 4000 miles on my SE camplate/oil pump with no problems. I wonder if they assembled the gerators wrong.
Mtclassic is offline   Reply With Quote Quick reply to this message
Old 05-30-2008, 02:44 PM   #7 (permalink)
Premium Member
 
aldean's Avatar
 
Join Date: Feb 2008
Location: Oakley, California
Posts: 359
aldean wants to know Dino or Syn?
Cam plate is the issue

Steve at GMR called the shop to find out what was up. The problem was the oil pressure was low at hot idle. It was determined that the problem was the SE cam plate and not the oil pump. Well I have learned a lesson here. Next time I decide on doing major work, I will load my bike on a trailor and take it to Steve. I wouldn't think twice about driving the 735 mile to have him do the work. He has gone out of his way to help me with this build. Thanks Steve for all your help.

Last edited by aldean; 05-30-2008 at 03:36 PM. Reason: correct spelling
aldean is offline   Reply With Quote Quick reply to this message
Old 05-30-2008, 05:30 PM   #8 (permalink)
IronButt
 
Join Date: Jun 2004
Location: montana
Posts: 2,385
Mtclassic wants to know Dino or Syn?
What was the issue with the cam plate?
Mtclassic is offline   Reply With Quote Quick reply to this message
Old 05-30-2008, 07:59 PM   #9 (permalink)
Premium Member
 
aldean's Avatar
 
Join Date: Feb 2008
Location: Oakley, California
Posts: 359
aldean wants to know Dino or Syn?
Cam Plate problem

It turns out that the holes were too big on the cam plate oil passages causing the pressure to be low. Plenty of volume but not the expected oil pressure.
aldean is offline   Reply With Quote Quick reply to this message
Old 05-31-2008, 12:41 AM   #10 (permalink)
Lifetime Premium
 
Join Date: Feb 2006
Location: Portland Oregon
Posts: 493
cts1950 wants to know Dino or Syn?
I have a 1999 that is a 103 now. I ran into this issue and have talked with others with 99 engines. THESE ENGINES ARE NOT A (A )OR B MODEL THAT CAME OUT IN 2000. The original twin cam is missing a boss on the engine case that closes a port that was used on the B model for the balance shaft lube. The A model has the same boss but serves as a plug only. The oil passage on the back of the new style cam plate SE Fueling or Delkron must be plugged to keep the oil from short circuiting back into the cam case it can not build oil pressure. This is a issue not talked about with the instruction sheet for the SE HV oil pump and cam-plate combo kit but there is a HD kit to plug this hole. This is a 1999 issue only. This has been discussed at length on this forum on this link there is alot of info there.
http://www.v-twinforum.com/forums/v-...help-help.html

Last edited by cts1950; 05-31-2008 at 12:47 AM.
cts1950 is offline   Reply With Quote Quick reply to this message
Old 10-04-2012, 12:27 AM   #11 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: Camarillo, CA
Posts: 4
bikepsych wants to know Dino or Syn?
I just had the SE Cam Plate and oil pump installed. Today as I was heading in to work, I glanced down at the oil pressure and it was sitting around 50psi. Is this a problem? Usually it hung out around 32psi. Not sure what the relief valve is set at. I thought the oil pump was to be high volume vice high pressure. Although depending on the size of the oil galleys and passages its possible that the pressure has increased. I just hope that there is no blockage prior to the relief valve that is causing this increase.

BG
bikepsych is offline   Reply With Quote Quick reply to this message
Old 10-04-2012, 08:12 AM   #12 (permalink)
Banned
 
Join Date: Jul 2012
Location: Texas
Posts: 5,840
webco2 wants to know Dino or Syn?
Quote:
Originally Posted by aldean View Post
I have a 99 Road King at a shop having a GMR 107 kit with the RR615 cam being installed. I had them order and install the Screamin Eagle cam plate and high volume oil pump part # 25283-07. They called me and said the oil pump didn't work. They said they replaced the oil pump again and that one didn't work either. They said they went ahead and installed the oil pump with the one that the owner uses in his bikes which is the same price. So that tells me they didn't go with a feuling oil pump. Are there other oil pumps that still have the high volume? Could they have been doing something wrong with the install? I'm concerned now....Any input will be greatly appreciated.
I'll bet they did not plug off the unused oil gallery .


webco2 is offline   Reply With Quote Quick reply to this message
Old 10-04-2012, 08:15 AM   #13 (permalink)
Banned
 
Join Date: Jul 2012
Location: Texas
Posts: 5,840
webco2 wants to know Dino or Syn?
Quote:
Originally Posted by bikepsych View Post
I just had the SE Cam Plate and oil pump installed. Today as I was heading in to work, I glanced down at the oil pressure and it was sitting around 50psi. Is this a problem? Usually it hung out around 32psi. Not sure what the relief valve is set at. I thought the oil pump was to be high volume vice high pressure. Although depending on the size of the oil galleys and passages its possible that the pressure has increased. I just hope that there is no blockage prior to the relief valve that is causing this increase.

BG
50psi is normal with 20w50 oil. It'll drop to around 35psi when it's heated up to operating temp.



webco2 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the V-Twin Forum : Harley-Davidson Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. WE WILL SEND A CONFIRMATION EMAIL TO THE ADDRESS YOU PROVIDE. If the email address is NOT VALID, you will not be given access to the system!
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
(C)2001-2012 V-twinForum.com All Rights Reserved (C)2001- V-twinForum.com All Rights Reserved
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum