Speedometer quit, 2004 Ultra : V-Twin Forum: Harley Davidson Forums
» Sponsors

» Insurance
Go Back   V-Twin Forum : Harley-Davidson Motorcycle Forums > General Discussion Forums > Harley-Davidson Touring
New User? Register Forgot Password

Reply
 
LinkBack Thread Tools Display Modes
Old 12-07-2012, 10:54 AM   #1 (permalink)
FNG :)
 
Join Date: Nov 2012
Location: Northwest
Posts: 16
RideSlow2004 wants to know Dino or Syn?
Speedometer quit, 2004 Ultra

Bike got really hosed, and speedo quit. Radio went weird, also. Had the fairing off, cleaned all the connections, dried it out as best I could, radio came back OK, but speedo is out. Kinda want to get it back, as I was coming up on 76,000 miles. Any thoughts?
RideSlow2004 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-07-2012, 10:55 PM   #2 (permalink)
Premium Member
 
mgb939's Avatar
 
Join Date: Apr 2006
Location: Nebraska
Posts: 531
mgb939 wants to know Dino or Syn?
Quote:
Originally Posted by RideSlow2004 View Post
Bike got really hosed, and speedo quit. Radio went weird, also. Had the fairing off, cleaned all the connections, dried it out as best I could, radio came back OK, but speedo is out. Kinda want to get it back, as I was coming up on 76,000 miles. Any thoughts?
You need to see if the speedo will pass the "WOW" test. Press trip reset button and turn on ignition, speedo hand should sweep and the speedo lights should come on( ck eng, low fuel, batt, security).
__________________


2009 FLHTCU A Black Ultra Classic
HD Tall Boy Seat
Ness Big Sucker A/C
V&H Slip-ons
V&H Fuel-Pak
Stage 1 HD Download
HD Oil Cooler
HD Oil Temp Gauge
Soos 1" floorboard ext.
mgb939 is offline   Reply With Quote
Old 12-08-2012, 06:52 AM   #3 (permalink)
IronButt
 
Join Date: Apr 2011
Location: indiana
Posts: 377
brownfoxx1 wants to know Dino or Syn?
did you put some di-elecrical grease on all connections? somebody found a better grease than di-electrical but i forgot to write it down.
brownfoxx1 is offline   Reply With Quote
Old 01-06-2013, 11:08 PM   #4 (permalink)
FNG :)
 
Join Date: Oct 2007
Location: Reno, Nevada
Posts: 7
05ultra1 wants to know Dino or Syn?
I would look at the speed sensor. Just had one go on my 05 Ultra at 127,500 miles. Speedo jumps around (sometimes quits) odometer messes up, turn signals sometimes won't cancel, idle will be affected.... Simple thing to change yourself.
05ultra1 is offline   Reply With Quote
Old 01-09-2013, 09:02 PM   #5 (permalink)
FNG :)
 
Nitro-Fish's Avatar
 
Join Date: Dec 2010
Location: Va
Posts: 11
Nitro-Fish wants to know Dino or Syn?
Hmm, I just posted this in another thread:

.....I wanted to ask a few things based on personal experience. When the bike dies, are you slowing or under acceleration? You mentioned the radio was going crazy, was the automatic volume control (increased volume with increased speed) working? Did the cruise quit working all together while you were having your problems? Did you notice if the turn signals were auto cancelling the way they should? Was the bike running "flat" when trying to accelerate? All of the above happened to me on my 2002 Ultra when the speed sensor went bad! The problems came and went at first then everything finally went at one time; pulled the speed sensor & it looked like a porcupine. Part was like $55 bucks & it took about an hour to replace; this took place right around 20,000 miles on mine.........

I forgot to mention the no speedometer in the above post, but yep that went out too! You too may want to do a search on speed sensor symptoms & see if your bike is doing the same thing.
__________________
2000 FXDL
2002 FLHTCUI
Nitro-Fish is offline   Reply With Quote
Old 05-11-2013, 07:43 PM   #6 (permalink)
FNG :)
 
Join Date: Nov 2012
Location: Northwest
Posts: 16
RideSlow2004 wants to know Dino or Syn?
Tried everything, no joy, it was dead. New one installed and working great.
RideSlow2004 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
(C)2001-2012 V-twinForum.com All Rights Reserved (C)2001- V-twinForum.com All Rights Reserved
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum