'98 Road King erratic idle : V-Twin Forum: Harley Davidson Forums
» Sponsors

» Insurance
Go Back   V-Twin Forum : Harley-Davidson Motorcycle Forums > Technical Discussion Forums > Evolution Engine Technical Discussion
New User? Register Forgot Password

Reply
 
LinkBack Thread Tools Display Modes
Old 07-16-2009, 12:23 PM   #1 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: TUCSON,AZ.
Posts: 9
tombardier wants to know Dino or Syn?
Angry '98 Road King erratic idle

I have a '98 Road King Classic with EFI. This engine has an Edwards T-5 cam and the normal H/D head work. Bike starts fine, runs good till engine reaches operating temp. Then the idle goes up and down, fast and slow, up and down. Dealer has thrown his hands in the air. I just replaced the cylinder temp sensor but that didn't help. I don't show any codes. Dealer didn't see any codes. Help!!!

Tom
tombardier is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-16-2009, 02:33 PM   #2 (permalink)
FNG :)
 
Join Date: Mar 2008
Location: California
Posts: 11
bmiknarf wants to know Dino or Syn?
maybe you've already been down this road: you have an IDE SPEED CONTROL ACTUATOR KIT part # 27272-95. if you wrench you can replace it, but i think it still has to be adjusted by the dealer. just a thought.
bmiknarf is offline   Reply With Quote
Old 07-16-2009, 02:58 PM   #3 (permalink)
FNG :)
 
mudhauler's Avatar
 
Join Date: Feb 2008
Location: Omaha NE.
Posts: 19
mudhauler wants to know Dino or Syn?
Something you may want to check are the gasketts at the
throtle body,where it connects to the cylinders.
Mine was doing the same thing,SUCKING AIR, causing the problem...
__________________
1996 FLHTCUI
A/N Big sucker air
A/N Fuel tuner
EV 27 cam
True duals into Wild Pig Pipes:
mudhauler is offline   Reply With Quote
Old 07-16-2009, 08:48 PM   #4 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: TUCSON,AZ.
Posts: 9
tombardier wants to know Dino or Syn?
Thanks a lot. I just bought the bike and that will give me a starting point.
tom
tombardier is offline   Reply With Quote
Old 07-16-2009, 08:50 PM   #5 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: TUCSON,AZ.
Posts: 9
tombardier wants to know Dino or Syn?
Thanks a lot. Is there any easy way to check the gaskets or am I best just to replace them?

Tom
tombardier is offline   Reply With Quote
Old 07-17-2009, 03:37 AM   #6 (permalink)
IronButt
 
Join Date: Apr 2009
Location: South Central Illinois
Posts: 182
Ted Zackro wants to know Dino or Syn?
Hi Tom,
I have a 98 FLHTCUI that has the same MM Fuel Injection as your FLHRCI. Before installing my new and expensive ($74.20) ET sensor I tried the following:
*Unplugging/reconnecting the ET, IT and the TPS sensors,
*Checking for Power and Functionality with a Sunpro Sensor Probe CP9085 per the accompanying instructional booklet. The tests showed I had power to the sensors and that they were functioning. This tester is very rudimentary at best having only cost around $40 about 15 years ago (see jpeg). It will not tell you the resistance to temperature values that the ECM is seeing. For this you will need a dealer’s Scanlyzer.
*I also tried starting the bike up from cold with the original ET unplugged which resulted in a high rpm only idling,
*I let the engine cool off and reconnected the original ET sensor back in and restarted with the engine idling significantly lower which allowed me to adjust the hot idle down to about 950-1000 RPM.
From all this I conclude that I had an intermittent/poor connection at one of the sensor connectors.
To date I have only rode the bike about 60 miles with no erratic idle/no other problems. I have not precluded that I may still have some issues but will get back to you if and when.
I hope you find this helpful?
Best Regards,
Attached Thumbnails
Click image for larger version

Name:	Sensor_Probe_With_Booklet.jpg
Views:	69
Size:	47.0 KB
ID:	54614  
__________________
Zman
Ted Zackro is offline   Reply With Quote
Old 07-17-2009, 07:02 AM   #7 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: TUCSON,AZ.
Posts: 9
tombardier wants to know Dino or Syn?
Hi Ted, Thanks for getting back to me. After I installed the new ET sensor (which took 10 minutes 'cause you don't have to remove gas tank, coil, or anything) I went for a ride. When I first took off the bike idled down nicely. Better than it had before. But after a few miles and a few more stops it went back to the old up and down, up and down. I am wondering if the connector on top of the Et sensor is bad. I will investigate and let you know. Thanks for your feedback. I really appreciate it. Someone else suggested to check intake gaskets for air leaks. This could be a possibility also. Thanks again.
Tom.
tombardier@hotmail.com
tombardier is offline   Reply With Quote
Old 07-17-2009, 07:06 AM   #8 (permalink)
IronButt
 
BigMike's Avatar
 
Join Date: Jul 2004
Location: Roswell, GA
Posts: 2,547
BigMike wants to know Dino or Syn?
Have you sprayed carb cleaner around the intake gaskets where it meets the head? If the engine wants to die when you do that, it's an intake leak.

The best solution is to rip out that MM EFI and switch to a carb.
__________________
2002 Road King
95" - HQ0034 cams - Big Boyz Street Port - Rinehart TD – SERT
92HP/102TQ
Paint By Attitude Custom Painting
BigMike is offline   Reply With Quote
Old 07-17-2009, 07:18 AM   #9 (permalink)
Site Sponsor
 
Join Date: Sep 2008
Location: Huntington, New York
Posts: 255
rosascycle wants to know Dino or Syn?
Did you or the dealer adjust the idle mixture screws to set front and rear air fuel ratio at hot idle? If you would like feel free to call and I'll be glad to explain setting all 3 Idle setting on the M&M injection system 1 Cold idle speed 2 Hot idle speed and 3 idle mixture settings
rosascycle is offline   Reply With Quote
Old 07-17-2009, 03:23 PM   #10 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: TUCSON,AZ.
Posts: 9
tombardier wants to know Dino or Syn?
Thanks Big Mike. In fact I did mention to the dealer about switching to a carb and he just rolled his eyes like I was asking for the economy to be back to normal. He mumbled something about ECM and wiring harnesses and then a small tear rolled down his cheek. I figured it was best to try and fix the EFI. So I am going to test the intake gaskets as you suggested. Thanks again.
Tom
tombardier is offline   Reply With Quote
Old 07-22-2009, 10:00 AM   #11 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: Pekin,ILL
Posts: 3
tommyboy3201 wants to know Dino or Syn?
Same Issues

I am having a similar problem on my 96 roadking In the spring it was idling up and down and then would correct itself. Yesterday I started the bike and it went right to 2000 RPM and stayed there. I turned the bike off,started it again and it went to 3000 RPM and stayed there. I am waiting for a guy to put on scanalizer to see what codes it throws. I thought it might be the TPS but the dealer says it's the engine temp sensor. I am going to check my connections and see if that helps. Tom
tommyboy3201 is offline   Reply With Quote
Old 07-24-2009, 09:20 AM   #12 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: TUCSON,AZ.
Posts: 9
tombardier wants to know Dino or Syn?
Hi Tom....I just replaced the ETS and it did no good at all. If you unplug your ETS and start the bike it will go into a real fast idle. Maybe your connection at the top of the ETS is bad. While the bike is idling fast try wiggling the connection and see if it idles down. I have heard this connection can fail. I tried this on my bike but the idle keeps going up and down at a steady pace. Up and down, up and down. Well you get the picture. Good luck. I don't know what to try next.
Tom
tombardier is offline   Reply With Quote
Old 07-27-2009, 04:07 PM   #13 (permalink)
FNG :)
 
Join Date: Apr 2006
Location: essex ont.
Posts: 11
se2 deuce wants to know Dino or Syn?
i have cured this problem on a 2002 road king if it is injected the wires for the injector, brake and have to be replaced no code will show for this problem you can move the wires around when the problem is going on and sometimes it clears it up
se2 deuce is offline   Reply With Quote
Old 07-30-2009, 01:04 AM   #14 (permalink)
IronButt
 
Join Date: May 2009
Location: Texas
Posts: 494
2000FiveOh wants to know where he is and how he got here
Quote:
Originally Posted by rosascycle View Post
Did you or the dealer adjust the idle mixture screws to set front and rear air fuel ratio at hot idle? If you would like feel free to call and I'll be glad to explain setting all 3 Idle setting on the M&M injection system 1 Cold idle speed 2 Hot idle speed and 3 idle mixture settings
This would make an excellent sticky if you have time to write something up. I would definitely love to read anything that would help with getting a tight idle on the MM set up.
__________________
2000 Road King, 96", K&N AC, Andrews 26G cams, Pre-EPA SE Slip Ons, 3:37 Primary gearing, EFI to carb, 105,000 and still rolling
2000FiveOh is offline   Reply With Quote
Old 07-31-2009, 07:51 AM   #15 (permalink)
FNG :)
 
Join Date: Jul 2009
Location: TUCSON,AZ.
Posts: 9
tombardier wants to know Dino or Syn?
Hi, thanks for the reply. I will certainly try this. Did you only have idle problems on your Road King? The up and down idle is the only problem I am having. It goes up and down at a steady rate. Drives me nuts.

Tom
tombardier is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
(C)2001-2012 V-twinForum.com All Rights Reserved (C)2001- V-twinForum.com All Rights Reserved
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum