Speedo quit! WTF? : V-Twin Forum: Harley Davidson Forums
» Sponsors

» Insurance
Go Back   V-Twin Forum : Harley-Davidson Motorcycle Forums > Technical Discussion Forums > Electrical, Wiring and Lighting
New User? Register Forgot Password

Reply
 
LinkBack Thread Tools Display Modes
Old 05-01-2005, 10:52 PM   #1 (permalink)
IronButt
 
Join Date: Sep 2003
Location: West TX
Posts: 389
toddlerp wants to know Dino or Syn?
Speedo quit! WTF?

Is there a way to test the functing of a HD electronic speedometer? The fuse is fine, the wires under the counsel are okay. It just quit registering MPH and odometer/ trip meter in the middle of a ride.

The light works and all other functions on the bike work.

It is on my 2002 Deuce.
toddlerp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-01-2005, 11:01 PM   #2 (permalink)
2005 Road King Classic
 
bbrowncods's Avatar
 
Join Date: Jul 2004
Location: VA
Posts: 1,632
bbrowncods wants to know Dino or Syn?
I hate it when that happens. Now you'll have to go buy a new one with a tach built in or the nostalgic look, etc...

I try to think positive!
bbrowncods is offline   Reply With Quote
Old 05-01-2005, 11:16 PM   #3 (permalink)
IronButt
 
Fourcats's Avatar
 
Join Date: Apr 2005
Location: Longview, Washington
Posts: 1,718
Fourcats wants to know Dino or Syn?
Do a Speedo Sensor search...
Fourcats is offline   Reply With Quote
Old 05-01-2005, 11:26 PM   #4 (permalink)
IronButt
 
toybox99615's Avatar
 
Join Date: May 2004
Location: Alaska
Posts: 4,253
toybox99615 wants to know Dino or Syn?
Talking digital speedometer testing

If the speedometer lights up when the bike is on the procedure goes something like this.

The basic test for a digital speedometer is:
turn on ignition and see if there is an odometer reading
yes there is odometer reading then press the trip button
does it change to the trip mode reading
yes no problem
no replace spedometer
No there is no spedometer reading then replace speedometer

If above is yes to the odometer and trip reading then turn off ignition
hold down trip button and turn on ignition (now your in diagnostic mode)
there are 10 readings in this mode. by pressing the button you move from one to another. If any problem exist the mode will read XX set if there is no promblem mode will read XX clear.

Depending upon which mode is set you can isolate the problem. For a good speedometer all modes are to be clear.

The exact diagnostic code are in the Harley service manuals. A fairly simple procedure to do. But a procedure that requires a manual for the charts.

The above is a short version from the H/D manual. I've done this on a few bikes and it really works well most of the time. Then of course there is the few times when things don't go as planned.

Once again this is another example of why you've got to have a manual for your bike. True H/D gets a lot for a manual. But if you did one procedure like the speedometer test and saved the cost of a service call at the dealer your ahead of the money game.
__________________
Rode the ALCAN and will try it again.

Last edited by toybox99615; 05-01-2005 at 11:36 PM.
toybox99615 is offline   Reply With Quote
Old 05-02-2005, 12:15 AM   #5 (permalink)
Harris
Guest
 
Posts: n/a
It sure sounds like your speedo sensor. The magnets on it get eventually pick up metal bits. Pull it and clean it off. If that doesn't work, you need a new sensor, not a new speedo. If the needle makes the sweep when you're in diagnostic mode, all the more reason to suspect this.

Harris
  Reply With Quote
Old 05-02-2005, 12:33 AM   #6 (permalink)
IronButt
 
Join Date: Sep 2003
Location: West TX
Posts: 389
toddlerp wants to know Dino or Syn?
I will look at the sensor. Thanks guys. Your replies are much appreciated.
toddlerp is offline   Reply With Quote
Old 05-02-2005, 12:38 AM   #7 (permalink)
IronButt
 
Join Date: Sep 2003
Location: West TX
Posts: 389
toddlerp wants to know Dino or Syn?
When I performed the test d02set was shown, all others were clear.
toddlerp is offline   Reply With Quote
Old 05-06-2005, 09:20 PM   #8 (permalink)
IronButt
 
Join Date: Sep 2003
Location: West TX
Posts: 389
toddlerp wants to know Dino or Syn?
Cleaned Sensor but to no avail

The sensor was full of chips, I cleaned and re-installed her. But after a quick test ide, she still does not work. Can the sensor be checked for functionality?
toddlerp is offline   Reply With Quote
Old 05-06-2005, 10:11 PM   #9 (permalink)
IronButt
 
Fourcats's Avatar
 
Join Date: Apr 2005
Location: Longview, Washington
Posts: 1,718
Fourcats wants to know Dino or Syn?
Good question, I don't know. Mine went out, I swapped it with another bike...and they got the problem . A new sensor is $55.
Fourcats is offline   Reply With Quote
Old 05-06-2005, 11:37 PM   #10 (permalink)
IronButt
 
road_king's Avatar
 
Join Date: Oct 2004
Location: Maryland
Posts: 1,799
road_king wants to know Dino or Syn?
Quote:
Originally Posted by toddlerp
The sensor was full of chips, I cleaned and re-installed her. But after a quick test ide, she still does not work. Can the sensor be checked for functionality?
Yes ther is a way to test the speed sensor but it involves fabricating a test harness and using HD-41354 spedometer tester.

A couple easy things to verify are 12v on red wire to speedo sensor.
Also, make sure the black wire is a good ground.

I'd bet the sensor itself is bad as others have indicated.
road_king is offline   Reply With Quote
Old 05-07-2005, 12:04 PM   #11 (permalink)
IronButt
 
Join Date: Dec 2003
Location: southern calif
Posts: 366
sportydave wants to know Dino or Syn?
this happened to my bike twice ... I turned the ignition off and back on and it started to work ... I think it might be in the switch... but all is fine now and no more probs for now ...
sportydave is offline   Reply With Quote
Old 05-08-2005, 05:10 PM   #12 (permalink)
IronButt
 
Join Date: Sep 2003
Location: West TX
Posts: 389
toddlerp wants to know Dino or Syn?
UPDATE Problem solved THANKS

It was the speed sensor. I replaced it and the speedo works, the idle is back to normal, and the turning signals cancel as they should. Life is good again.

Thanks a million fellas.
toddlerp is offline   Reply With Quote
Old 05-10-2005, 09:26 PM   #13 (permalink)
FNG :)
 
Join Date: Mar 2003
Location: Lincoln, Nebraska
Posts: 1
t2597tb wants to know Dino or Syn?
I have a 2000 Road King Classic and the speedometer just quit working. It sounds just like the above problem. The speedometer and the odometer quit working and the turn signals don't cancel. I feel dumb asking this, but where is the speed sensor on my bike?
t2597tb is offline   Reply With Quote
Old 05-10-2005, 10:02 PM   #14 (permalink)
IronButt
 
Fourcats's Avatar
 
Join Date: Apr 2005
Location: Longview, Washington
Posts: 1,718
Fourcats wants to know Dino or Syn?
The sensor is by the dip stick, takes a 3/16 allen. {You may have to pull the chrome cover on the starter to replace the sensor}
Fourcats is offline   Reply With Quote
Old 05-16-2005, 07:55 PM   #15 (permalink)
IronButt
 
Join Date: Sep 2002
Location: Fort Worth TX
Posts: 6,363
HDWRENCH wants to know Dino or Syn?
I love to route the wire it is so much fun yea right.
HDWRENCH is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
(C)2001-2012 V-twinForum.com All Rights Reserved (C)2001- V-twinForum.com All Rights Reserved
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum